RTC Forums
November 30, 2021, 07:33:01 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 
   Home   Help Login Register  
Pages: [1]
  Print  
Author Topic: HTTPS Listener dies  (Read 498 times)
StephenMott
RTC License+
****
Posts: 7


« on: August 26, 2021, 10:10:50 PM »

I recently managed to get a proper SSL license for our server (free using CertBot), so I put it live and all appeared to work fine, but a few hours later it went into a not responding mode Chrome gives ERR_CONNECTION_CLOSED.

So initial thought was it was the way I'd implemented the SSL code, so I switched it to use the rtcSSecTest example and GetServerCryptPlugin, again works fine, loads the certificate, but again at some random time afterwards just dies.

Next I thought it might be the NexusDB memory manager the server uses, I've a vague memory of it initially causing problems on Win32 years back, but nope, no change.

I then enabled RTC_DEBUG to see if that would give any clues, which it does, they just don't make any sense to me, the log shows:

Code:
2021-08-26 21:52:12.327; TRtcSocketServerProvider CryptPlugin.DataReceivedEx Exception! EAssertionFailed: Assertion failure (S:\_StreamSec\Source\StreamSecII.pas, line 7869)
2021-08-26 21:52:12.346; TRtcSocketServerProvider CryptPlugin.BeforeDisconnect Exception! EAccessViolation: Access violation at address 0000000000B161CA in module 'Gateway.exe'. Read of address 0000000000000000

Which is StreamSec failing on InternalFindPrivateKey, but why I've no idea...

This is all on Win64, Delphi 10.2, RTCSDK v9.02, StreamSec Tools 2.1.9.243. (I did try checking for updates, but the owner area on https://www.streamsec.com/ seems broken, and the downloads aren't downloading when you click on them in here..?)
Logged
D.Tkalcec (RTC)
Administrator
*****
Posts: 1861


« Reply #1 on: August 26, 2021, 10:50:34 PM »

You might want to report there errors to the developer of StreamSec, since both of these exceptions are being thrown out of events linked to the SSL encryption plugin and you are using StreamSec Tools 2.x for that purpose.

Best Regards,
Danijel Tkalcec
Logged
StephenMott
RTC License+
****
Posts: 7


« Reply #2 on: August 27, 2021, 01:04:26 AM »

Hi Danijel,

OK thanks, I'll forward it onto Henrick, does your lib still work with Secure Black box in case he doesn't reply?

Any idea why your download page isn't working?

Steve..
Logged
D.Tkalcec (RTC)
Administrator
*****
Posts: 1861


« Reply #3 on: August 27, 2021, 07:20:48 AM »

You'll have to ask the developers of Secure Black Box if their components work with the latest RTC SDK version.

Which download page are you refferring to?

The "Downloads" section on this Forum (for the RTC SDK) is working fine from here (Europe, Croatia).
Is it possible that you have an old Bookmark in your web browser, pointing to an outdated URL?

Here is the current URL to the "Downloads" area on this Forum:
https://rtcforum.teppi.net/index.php?board=15.0

Best Regards,
Danijel Tkalcec
Logged
StephenMott
RTC License+
****
Posts: 7


« Reply #4 on: August 27, 2021, 01:24:40 PM »

Didn't you have some Secure Black Box examples in the SDK like the StreamSec ones?

I mean the fact his registered user download page http://download.streamsec.net/ doesn't exist anymore, doesn't inspire confidence, what if we can't buy 4 anymore? Your last download post says:

"However, if you need security certification, you might have to show that your server only supports TLS 1.2 and up, and in such case you have to use StreamSec Tools 4.0 or later and set EnableLegacyTLS to FALSE."

For yours I just clicked the download topic under subscriptions it points to the same page as your link. I go into the download page e.g. https://rtcforum.teppi.net/index.php?topic=1803.msg5739#msg5739 then click on the "Download RealThinClient SDK v9.51 - released May 25th 2020." link, it opens a new browser tab, then closes it, but no download starts. This is latest Chrome, no VPN or anything from the UK.
Logged
D.Tkalcec (RTC)
Administrator
*****
Posts: 1861


« Reply #5 on: August 27, 2021, 01:56:12 PM »

I did not have examples for using Secure Black Box, only StreamSec Tools.

Now, I see what you mean by "RTC downloads not working" with Chrome. Everything worked fine with Firefox (which I am using), but Chrome seems to have a problem with these URLs, probably because they are using a redirect. Anyway ... I've fixed the download links for all RTC SDK versions in the "Downloads" area to point directly at each file, so you should be able to download them with Chrome now.

As for your 3rd-party encryption plugin issues, please contact the developers of StreamSec and/or Secure Black Box directly.

Best Regards,
Danijel Tkalcec
Logged
StephenMott
RTC License+
****
Posts: 7


« Reply #6 on: August 27, 2021, 02:49:25 PM »

Strange, sure they were an option at some point, I remember looking at them and StreamSec at the same time, anyway I've emailed their sales about it.

Thanks download now working.

I am worried though, what should I do if neither option work? I really need to have HTTPS working..

Steve..
Logged
D.Tkalcec (RTC)
Administrator
*****
Posts: 1861


« Reply #7 on: August 27, 2021, 03:35:56 PM »

For what it's worth, I do NOT have any problems accessing the StreamSec Forum and Downloads area for registered users, either using Firefox or Chrome on Windows:
  https://support.streamsec.net/forum/

Best Regards,
Danijel Tkalcec
Logged
StephenMott
RTC License+
****
Posts: 7


« Reply #8 on: August 27, 2021, 03:49:20 PM »

Well I've tried that link from Chrome, Safari (Mac & iPad) and Firefox, all can't connect..

Firefox gives: An error occurred during a connection to support.streamsec.net. PR_END_OF_FILE_ERROR
Chrome: support.streamsec.net unexpectedly closed the connection... ERR_CONNECTION_CLOSED
Safari: Safari can’t open the page “https://support.streamsec.net/forum/” because Safari can’t establish a secure connection to the server “support.streamsec.net”.

Which oddly is very similar to what I get trying to connect to mine after its been running for a while..Huh (but its not just me connecting to mine, I get morning emails telling me its stopped again..)

Steve..
Logged
D.Tkalcec (RTC)
Administrator
*****
Posts: 1861


« Reply #9 on: August 27, 2021, 04:21:50 PM »

Now that you have mentioned Safari, I've tried it from my iPhone and I can confirm that it gives me the error "Safari cannot open the page because it could not establish a secure connection to the server" for https://support.streamsec.net , which makes no sense, because my iPhone is connected to the same router as my two Windows PCs, which have no problems opening it (using Edge or Firefox on Windows 10, using Firefox or Chrome on Windows 7).

Anyway ... if you want to get to the bottom of this, you could try sending an E-mail to StreamSec support. You should see the E-Mail address on their Contacts page, which is hosted on a different domain and works from my iPhone using Safari:
https://www.streamsec.com/index.php?id=contact

Best Regards,
Danijel Tkalcec
Logged
StephenMott
RTC License+
****
Posts: 7


« Reply #10 on: August 27, 2021, 04:29:15 PM »

Hi Danijel,

I did email support@streamsec.se yesterday, no reply so far.

I just tried from a PC and it does connect to https://support.streamsec.net/forum/ OK, so could be Mac related, but my server's just died again https://ingot.cloud/, and it's dead from a PC too.

Steve..
Logged
StephenMott
RTC License+
****
Posts: 7


« Reply #11 on: August 27, 2021, 04:45:26 PM »

I've posted this on his Forum now, hopefully he'll have some ideas..

Thanks..

Steve..
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.03 seconds with 17 queries.